программирование Вышел PHP 5.2.16 и конец поддержки 5.2.x

Команда разработчиков анонсировала внеочередное обновление для php 5.2 — php 5.2.16. Это обновление исправляет ошибку, которая обнаружилась сразу же в предыдущей версии, и еще одну. Обновление настоятельно рекомендовано всем, кто использует open_basedir

Надо отметить, что за последние пару дней это уже не первый релиз PHP, посвященный ошибкам и безопасности, которым «стрельнула» команда разработчиков

Главное то, что с этим обновлением прекращается поддержка ветки 5.2.x. Переход на новую версию 5.3.4 для некоторых пользователей закончится различными варнингами об устаревании функций и, как следствие, неработоспособность некоторых элементов или всего сайта — будьте осторожны и тестируйте заранее свои сайты перед обновлением, например, на виртуальных машинах


Версия 5.2.16 от 16-Dec-2010 включает всего два исправления

  • Исправлен баг #53517 (segfault в pgsql_stmt_execute() когда сервер postgres остановлен). (gyp at balabit dot hu)
  • Исправлен баг #53516 (Ошибка в обработке директивы open_basedir). (Ilia)

Главная новость «PHP 5.2.16 Released!» на php.net (англ.)
Устаревшие в php 5.3 функции и директивы (англ.)
RPM пакет php 5.2.16 с патчем fpm для CentOS 5 на стороннем репозитории

комментарии: 0
17/12/2010 09:49

Comments are closed.